Маскируем наш роутер в сети провайдера от TTL-фильтра

 

 Теория: 

В IPv4 TTL представляет собой восьмиразрядное поле IP-заголовка.
 Определяет максимальное количество хопов (hop, то есть прыжок, участок между маршрутизаторами), которые пакет может пройти. Наличие этого параметра не позволяет пакету бесконечно ходить по сети. Каждый маршрутизатор, при маршрутизации должен уменьшать значение TTL на единицу, но некоторые шлюзы можно настроить, чтобы игнорировать это. Пакеты, не достигшие адресата, но время жизни которых стало равно нулю, уничтожаются, а отправителю посылается сообщение ICMP Time Exceeded. Если требуется, чтобы пакет не был маршрутизирован (то есть принят только в своём сегменте), то выставляется TTL=1. На отправке пакетов с разным временем жизни основана трассировка их пути прохождения (traceroute). Максимальное значение TTL=255. Обычное начальное значение TTL=64 (зависит от ОС).

 Добавим правило в Mikrotik,  что бы с имитировать конечное устройство:

/ip firewall mangle add action=change-ttl chain=prerouting new-ttl=increment:1 passthrough=yes

выход из роутера в ван, чендж ттл на 64 и делов

/ip firewall mangle add action=change-ttl chain=postrouting new-ttl=set:64 out-interface-list="WAN" passthrough=yes
Один wlan закидываем в бридж, другой в WAN и цепляемся к телефону с МТС Тарифище. В правиле прописываем new TTL = 65. МТС ни о чём не догадывается =)

Маскируем наш роутер в сети провайдера от TTL-фильтра: 2 комментария

Добавить комментарий